<!doctype html>
<html lang="en-US">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="profile" href="https://gmpg.org/xfn/11">
    <script type="text/javascript">
var trackScrolling=false;
var trackScrollingPercentage=false;
var ScrollingPercentageNumber=25;
var stLogInterval=10*1000;
var cutOffTime=900;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='&#8220;Snowpiercer&#8221; is science fiction';
</script>

	<!-- This site is optimized with the Yoast SEO plugin v15.7 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>&quot;Snowpiercer&quot; is science fiction</title>
	<meta name="description" content="The pandemic has prompted people to discover tastes for things they previously did not care about or didn&#039;t care about. Gary, for example, found that" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="&quot;Snowpiercer&quot; is science fiction" />
	<meta property="og:description" content="The pandemic has prompted people to discover tastes for things they previously did not care about or didn&#039;t care about. Gary, for example, found that" />
	<meta property="og:url" content="https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/" />
	<meta property="og:site_name" content="Sunday Vision" />
	<meta property="article:published_time" content="2021-02-27T21:18:18+00:00" />
	<meta property="og:image" content="https://www.elcomercio.com/bundles/elcomerciocms/images/icons/social/article-placeholder.jpg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:image" content="https://www.elcomercio.com/bundles/elcomerciocms/images/icons/social/article-placeholder.jpg" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Mia Thompson">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="2 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.sundayvision.co.ug/#organization","name":"Sunday Vision","url":"https://www.sundayvision.co.ug/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.sundayvision.co.ug/#logo","inLanguage":"en-US","url":"https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo.png","width":320,"height":183,"caption":"Sunday Vision"},"image":{"@id":"https://www.sundayvision.co.ug/#logo"}},{"@type":"WebSite","@id":"https://www.sundayvision.co.ug/#website","url":"https://www.sundayvision.co.ug/","name":"Sunday Vision","description":"Complete News World","publisher":{"@id":"https://www.sundayvision.co.ug/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.sundayvision.co.ug/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/#primaryimage","inLanguage":"en-US","url":"https://www.elcomercio.com/bundles/elcomerciocms/images/icons/social/article-placeholder.jpg"},{"@type":"WebPage","@id":"https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/#webpage","url":"https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/","name":"\"Snowpiercer\" is science fiction","isPartOf":{"@id":"https://www.sundayvision.co.ug/#website"},"primaryImageOfPage":{"@id":"https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/#primaryimage"},"datePublished":"2021-02-27T21:18:18+00:00","dateModified":"2021-02-27T21:18:18+00:00","description":"The pandemic has prompted people to discover tastes for things they previously did not care about or didn't care about. Gary, for example, found that","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/"]}]},{"@type":"Article","@id":"https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/#article","isPartOf":{"@id":"https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/#webpage"},"author":{"@id":"https://www.sundayvision.co.ug/#/schema/person/15b34a33e5b478885ab362300bbd32b8"},"headline":"&#8220;Snowpiercer&#8221; is science fiction","datePublished":"2021-02-27T21:18:18+00:00","dateModified":"2021-02-27T21:18:18+00:00","mainEntityOfPage":{"@id":"https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/#webpage"},"commentCount":0,"publisher":{"@id":"https://www.sundayvision.co.ug/#organization"},"image":{"@id":"https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/#primaryimage"},"articleSection":"science","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/#respond"]}]},{"@type":"Person","@id":"https://www.sundayvision.co.ug/#/schema/person/15b34a33e5b478885ab362300bbd32b8","name":"Mia Thompson","image":{"@type":"ImageObject","@id":"https://www.sundayvision.co.ug/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0e8204c2685ab5f79769fa753257de84?s=96&d=mm&r=g","caption":"Mia Thompson"},"description":"\"Award-winning zombie scholar. Music practitioner. Food expert. Troublemaker.\""}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Sunday Vision &raquo; Feed" href="https://www.sundayvision.co.ug/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sunday Vision &raquo; Comments Feed" href="https://www.sundayvision.co.ug/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sunday Vision &raquo; &#8220;Snowpiercer&#8221; is science fiction Comments Feed" href="https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.sundayvision.co.ug/wp-includes/css/dist/block-library/style.min.css?ver=5.5' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.sundayvision.co.ug/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='sc-frontend-style-css'  href='https://www.sundayvision.co.ug/wp-content/plugins/shortcodes-indep/css/frontend-style.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp_automatic_gallery_style-css'  href='https://www.sundayvision.co.ug/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-v5-css'  href='https://www.sundayvision.co.ug/wp-content/themes/covernews-pro/assets/font-awesome-v5/css/fontawesome-all.min.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.sundayvision.co.ug/wp-content/themes/covernews-pro/assets/bootstrap/css/bootstrap.min.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css'  href='https://www.sundayvision.co.ug/wp-content/themes/covernews-pro/assets/slick/css/slick.min.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='sidr-css'  href='https://www.sundayvision.co.ug/wp-content/themes/covernews-pro/assets/sidr/css/jquery.sidr.dark.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://www.sundayvision.co.ug/wp-content/themes/covernews-pro/assets/magnific-popup/magnific-popup.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='sliderpro-css'  href='https://www.sundayvision.co.ug/wp-content/themes/covernews-pro/assets/slider-pro/css/slider-pro.min.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='covernews-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Lato:400,300,400italic,900,700|Source%20Sans%20Pro:400,400i,700,700i&#038;subset=latin,latin-ext&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='covernews-style-css'  href='https://www.sundayvision.co.ug/wp-content/themes/covernews-pro/style.css?ver=5.5' type='text/css' media='all' />
<style id='covernews-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.sundayvision.co.ug/wp-content/plugins/jetpack/css/jetpack.css?ver=9.3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.sundayvision.co.ug/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-js'></script>

<link rel="https://api.w.org/" href="https://www.sundayvision.co.ug/wp-json/" /><link rel="alternate" type="application/json" href="https://www.sundayvision.co.ug/wp-json/wp/v2/posts/4934" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sundayvision.co.ug/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sundayvision.co.ug/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5" />
<link rel='shortlink' href='https://www.sundayvision.co.ug/?p=4934' />
<meta name="framework" content="Redux 4.1.24" /><link rel="preconnect" href="https://cdnjs.cloudflare.com">

<!-- This site uses the Open External Links in a New Window plugin v1.4 by WebFactory Ltd. Download it for free at https://wordpress.org/extend/plugins/open-external-links-in-a-new-window/ -->


<style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="https://www.sundayvision.co.ug/xmlrpc.php">        <style type="text/css">
                        .site-title,
            .site-description {
                position: absolute;
                clip: rect(1px, 1px, 1px, 1px);
                display: none;
            }

            

        </style>
        <style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<link rel="icon" href="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Favicon.png" sizes="32x32" />
<link rel="icon" href="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Favicon.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Favicon.png" />
<meta name="msapplication-TileImage" content="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Favicon.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>

<body data-rsssl=1 class="post-template-default single single-post postid-4934 single-format-standard custom-background wp-custom-logo wp-embed-responsive default-content-layout default single-content-mode-default header-image-default align-content-left">


<div id="page" class="site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>

<div class="header-layout-1">
    <div class="top-masthead">

        <div class="container">
            <div class="row">
                                    <div class="col-xs-12 col-sm-12 col-md-8 device-center">
                        
                        <div class="top-navigation"><ul id="top-menu" class="menu"><li id="menu-item-2631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2631"><a href="https://www.sundayvision.co.ug/about-us/">About Us</a></li>
<li id="menu-item-2630" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2630"><a href="https://www.sundayvision.co.ug/dmca/">DMCA</a></li>
<li id="menu-item-2632" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2632"><a href="https://www.sundayvision.co.ug/contact-form/">Contact Form</a></li>
<li id="menu-item-2673" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2673"><a href="https://www.sundayvision.co.ug/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-2629" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2629"><a href="https://www.sundayvision.co.ug/editorial-policy/">Editorial Policy</a></li>
</ul></div>                    </div>
                                            </div>
        </div>
    </div> <!--    Topbar Ends-->
<header id="masthead" class="site-header">
        <div class="masthead-banner " data-background="">
        <div class="container">
            <div class="row">
                <div class="col-md-4">
                    <div class="site-branding">
                        <a href="https://www.sundayvision.co.ug/" class="custom-logo-link" rel="home"><img width="320" height="183" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20320%20183'%3E%3C/svg%3E" class="custom-logo" alt="Sunday Vision" data-lazy-srcset="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo.png 320w, https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo-300x172.png 300w" data-lazy-sizes="(max-width: 320px) 100vw, 320px" data-lazy-src="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo.png" /><noscript><img width="320" height="183" src="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo.png" class="custom-logo" alt="Sunday Vision" srcset="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo.png 320w, https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo-300x172.png 300w" sizes="(max-width: 320px) 100vw, 320px" /></noscript></a>                            <p class="site-title font-family-1">
                                <a href="https://www.sundayvision.co.ug/"
                                   rel="home">Sunday Vision</a>
                            </p>
                        
                                                    <p class="site-description">Complete News World</p>
                                            </div>
                </div>
                <div class="col-md-8">
                                    </div>
            </div>
        </div>
    </div>
    <nav id="site-navigation" class="main-navigation">
        <div class="container">
            <div class="row">
                <div class="kol-12">
                    <div class="navigation-container">





                        <button class="toggle-menu" aria-controls="primary-menu" aria-expanded="false">
                                <span class="screen-reader-text">Primary Menu</span>
                                 <i class="ham"></i>
                        </button>
                        <span class="af-mobile-site-title-wrap">
                            <a href="https://www.sundayvision.co.ug/" class="custom-logo-link" rel="home"><img width="320" height="183" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20320%20183'%3E%3C/svg%3E" class="custom-logo" alt="Sunday Vision" data-lazy-srcset="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo.png 320w, https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo-300x172.png 300w" data-lazy-sizes="(max-width: 320px) 100vw, 320px" data-lazy-src="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo.png" /><noscript><img width="320" height="183" src="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo.png" class="custom-logo" alt="Sunday Vision" srcset="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo.png 320w, https://www.sundayvision.co.ug/wp-content/uploads/2020/12/Sunday-Vision-Logo-300x172.png 300w" sizes="(max-width: 320px) 100vw, 320px" /></noscript></a>                            <p class="site-title font-family-1">
                                <a href="https://www.sundayvision.co.ug/"
                                   rel="home">Sunday Vision</a>
                            </p>
                        </span>
                        <div class="menu main-menu"><ul id="primary-menu" class="menu"><li id="menu-item-530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://www.sundayvision.co.ug">Home</a></li>
<li id="menu-item-531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://www.sundayvision.co.ug/top-news/">Top News</a></li>
<li id="menu-item-532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://www.sundayvision.co.ug/world/">World</a></li>
<li id="menu-item-533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://www.sundayvision.co.ug/economy/">Economy</a></li>
<li id="menu-item-534" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-534"><a href="https://www.sundayvision.co.ug/science/">Science and Health</a></li>
<li id="menu-item-535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://www.sundayvision.co.ug/tech/">Technology</a></li>
<li id="menu-item-536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://www.sundayvision.co.ug/sport/">Sport</a></li>
<li id="menu-item-537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://www.sundayvision.co.ug/entertainment/">Entertainment</a></li>
<li id="menu-item-3528" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3528"><a href="https://www.sundayvision.co.ug/contact-form/">Contact Form</a></li>
</ul></div>
                        <div class="cart-search">
                            <div class="af-search-wrap">
                                <div class="search-overlay">
                                    <a href="#" title="Search" class="search-icon">
                                        <i class="fa fa-search"></i>
                                    </a>
                                    <div class="af-search-form">
                                        <form role="search" method="get" class="search-form" action="https://www.sundayvision.co.ug/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                                    </div>
                                </div>
                            </div>
                        </div>


                    </div>
                </div>
            </div>
        </div>
    </nav>
</header>

</div>

    <div id="content" class="container">


        <div class="em-breadcrumbs font-family-1">
            <div class="row">
                <div role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="3" /><meta name="itemListOrder" content="Ascending" /><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="https://www.sundayvision.co.ug" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="https://www.sundayvision.co.ug/science/" itemprop="item"><span itemprop="name">science</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><a href="https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/" itemprop="item"><span itemprop="name">&#8220;Snowpiercer&#8221; is science fiction</span></a><meta itemprop="position" content="3" /></li></ul></div>            </div>
        </div>


            <div class="row">
                <div id="primary" class="content-area">
                    <main id="main" class="site-main">

                                                    <article id="post-4934" class="af-single-article post-4934 post type-post status-publish format-standard has-post-thumbnail hentry category-science">
                                <div class="entry-content-wrap">
                                    <header class="entry-header">

    <div class="header-details-wrapper">
        <div class="entry-header-details">
                            <div class="figure-categories figure-categories-bg">
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                </div>
                        <h1 class="entry-title">&#8220;Snowpiercer&#8221; is science fiction</h1>
            
                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    16 mins ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/vihaan/">
                Mia Thompson            </a>
        </span>
                    </span>
                        

                    </div>
    </div>
        <div class="aft-post-thumbnail-wrapper">    
                    <div class="post-thumbnail full-width-image">
                    <img fifu-featured="1" width="1024" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%200'%3E%3C/svg%3E" class="attachment-covernews-featured size-covernews-featured wp-post-image" alt="" title="" title="" data-lazy-src="https://www.elcomercio.com/bundles/elcomerciocms/images/icons/social/article-placeholder.jpg" /><noscript><img fifu-featured="1" width="1024" src="https://www.elcomercio.com/bundles/elcomerciocms/images/icons/social/article-placeholder.jpg" class="attachment-covernews-featured size-covernews-featured wp-post-image" alt="" title="" title="" /></noscript>                </div>
            
                </div>
</header><!-- .entry-header -->                                    

    <div class="entry-content">
        <div>
<p id="m12-11-13">The pandemic has prompted people to discover tastes for things they previously did not care about or didn&#8217;t care about.  Gary, for example, found that gardening, and not anything else he had done before last year, was the true dominant idea in his life;  A newsroom friend revealed her taste of vegetable fry, a sacred sacrilege for any self-respecting carnivore;  And I discovered the joy of science fiction.</p>
<p id="m59-1-60">In the starting course I went for the classics.  I read “Fahrenheit 451” by Ray Bradbury, “Is Android Dreaming of Electric Sheep?” By Philip K. Dick, but he also discovered authors like Ted Chiang. Also, I started listening to the podcast, “Guerra III” is my favorite, and watching series Television in Miserable Worlds In the middle of this exploration, you come across “Snowpiercer,” a series based on the same-sounding film directed by South Korean Bong Joon-ho.</p>
<p>Googling discovered that the director&#8217;s film Parasites was a quote from the French graphic novel, &#8220;Le Transperceneige,&#8221; first published in 1982. The graphic novel, films and TV series preserve the same essence of the post-apocalyptic narrative: after a nuclear catastrophe led mankind into an ice age New, as few survivors spent their lives in a 1001-car train called Snowpiercer, which circulates around the world. </p>
<p>Snowpiercer&#8217;s narrative delves into the problems of today&#8217;s society such as social injustice, class struggles and survival politics, with the aggravating factor that everything must be resolved within a train that no one can get out of.  In this story, Mr. Wilford resembles, in every respect, the character of Older Brother, the character of George Orwell in &#8220;1984&#8221;.  He set the rules for coexistence and is the only one who theoretically can change them.</p>
<p>If until now someone thinks that this post-apocalyptic science fiction story isn&#8217;t exactly appealing, it should be noted that the heroine of the series is Jennifer Connelly.  The data may go unnoticed by anyone who is not a fan of Darren Aronofsky&#8217;s films, but for the two thousand gay men who ended their teens watching &#8220;Requiem for a Dream&#8221; (2000) The presence of the New Yorker, without a doubt, adds a unique stamp to the story.</p>
<p>&#8220;Snowpiercer&#8221; is one of the few Netflix series, and I don&#8217;t know if it&#8217;s the only series that maintains the format for releasing a new chapter every week.  Imposing this form has two advantages: that one does not suffer from television embarrassment and that one can return to the details of the story.</p>
<p>This week, for example, after seeing Melanie, the character played by Connelly, leave the train looking for clues to re-colonizing Earth, I have been haunted by the idea that life is doomed to permanent confinement and how that might affect the relationships we have with others.</p>
</div>

<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="098ab77ba4b6d396bd87ca076f131772" data-index="100" style="">

</div>

<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-gravatar"><a  href='https://www.sundayvision.co.ug/author/vihaan/'><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" itemprop="image" data-lazy-src="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/sovety_04-biography.jpg"><noscript><img src="https://www.sundayvision.co.ug/wp-content/uploads/2020/12/sovety_04-biography.jpg" alt="" itemprop="image"></noscript></a></div><div class="saboxplugin-authorname"><a href="https://www.sundayvision.co.ug/author/vihaan/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Mia Thompson</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p class="sign">&#8220;Award-winning zombie scholar. Music practitioner. Food expert. Troublemaker.&#8221;</p>
</div></div><div class="clearfix"></div></div>                    <div class="post-item-metadata entry-meta">
                            </div>
                
	<nav class="navigation post-navigation" role="navigation" aria-label="Continue Reading">
		<h2 class="screen-reader-text">Continue Reading</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.sundayvision.co.ug/how-jane-fonda-leaded-and-continues-to-lead-the-workout-revolution/" rel="prev"><span class="em-post-navigation">Previous</span> How Jane Fonda Leaded and Continues to Lead the Workout Revolution</a></div></div>
	</nav>            </div><!-- .entry-content -->


                                </div>
                                
<div class="promotionspace enable-promotionspace">

        <div class="em-reated-posts  col-ten">
        <div class="row">
                            <h3 class="related-title">
                    More Stories                </h3>
                        <div class="row">
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article inside-img">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="https://cnnespanol.cnn.com/wp-content/uploads/2021/02/130129153750-jane-fonda-exercise-full-169-e1614379963443.jpg?quality=100&#038;strip=info">
                                        <a href="https://www.sundayvision.co.ug/how-jane-fonda-leaded-and-continues-to-lead-the-workout-revolution/"></a>
                                    </div>
                                </div>
                                                                <div class="figure-categories figure-categories-bg">

                                    <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                                </div>
                            </figure>

                            <figcaption>

                                <h3 class="article-title article-title-1">
                                    <a href="https://www.sundayvision.co.ug/how-jane-fonda-leaded-and-continues-to-lead-the-workout-revolution/">
                                        How Jane Fonda Leaded and Continues to Lead the Workout Revolution                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    16 hours ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/vihaan/">
                Mia Thompson            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article inside-img">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="https://www.filo.news/__export/1614372190097/sites/claro/img/2021/02/26/marley_portada.jpg_673822677.jpg">
                                        <a href="https://www.sundayvision.co.ug/tinker-science-presents-its-eighth-season/"></a>
                                    </div>
                                </div>
                                                                <div class="figure-categories figure-categories-bg">

                                    <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                                </div>
                            </figure>

                            <figcaption>

                                <h3 class="article-title article-title-1">
                                    <a href="https://www.sundayvision.co.ug/tinker-science-presents-its-eighth-season/">
                                        Tinker Science presents its eighth season                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 day ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/vihaan/">
                Mia Thompson            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article inside-img">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="https://static2.leonoticias.com/www/multimedia/202102/26/media/cortadas/programamuseo3-kuoC--984x468@Leonoticias.jpg">
                                        <a href="https://www.sundayvision.co.ug/science-heritage-and-territory-are-thematic-axes-of-the-energy-museum-expo-program-for-2021/"></a>
                                    </div>
                                </div>
                                                                <div class="figure-categories figure-categories-bg">

                                    <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                                </div>
                            </figure>

                            <figcaption>

                                <h3 class="article-title article-title-1">
                                    <a href="https://www.sundayvision.co.ug/science-heritage-and-territory-are-thematic-axes-of-the-energy-museum-expo-program-for-2021/">
                                        Science, heritage and territory are thematic axes of the Energy Museum Expo program for 2021                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 day ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/vihaan/">
                Mia Thompson            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article inside-img">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="https://www.agronewscastillayleon.com/sites/default/files/field/image/irta-danone-bienestar.jpg">
                                        <a href="https://www.sundayvision.co.ug/ocv-asserts-that-animal-welfare-is-a-science-that-should-be-included-in-the-veterinary-profession/"></a>
                                    </div>
                                </div>
                                                                <div class="figure-categories figure-categories-bg">

                                    <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                                </div>
                            </figure>

                            <figcaption>

                                <h3 class="article-title article-title-1">
                                    <a href="https://www.sundayvision.co.ug/ocv-asserts-that-animal-welfare-is-a-science-that-should-be-included-in-the-veterinary-profession/">
                                        OCV asserts that &#8220;animal welfare is a science that should be included in the veterinary profession&#8221;                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    2 days ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/vihaan/">
                Mia Thompson            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article inside-img">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="https://www.eltiempo.com/files/og_paste_img/uploads/2021/02/25/6037e36524289.jpeg">
                                        <a href="https://www.sundayvision.co.ug/china-is-showing-lunar-samples-brought-by-change-5-science-life/"></a>
                                    </div>
                                </div>
                                                                <div class="figure-categories figure-categories-bg">

                                    <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                                </div>
                            </figure>

                            <figcaption>

                                <h3 class="article-title article-title-1">
                                    <a href="https://www.sundayvision.co.ug/china-is-showing-lunar-samples-brought-by-change-5-science-life/">
                                        China is showing lunar samples brought by Chang&#8217;e 5 &#8211; Science &#8211; Life                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    2 days ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/vihaan/">
                Mia Thompson            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article inside-img">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="https://ep01.epimg.net/verne/imagenes/2021/02/10/articulo/1612972566_746660_1612974276_rrss_normal.jpg">
                                        <a href="https://www.sundayvision.co.ug/28-funny-tweets-about-exercises-that-you-can-read-without-sweat/"></a>
                                    </div>
                                </div>
                                                                <div class="figure-categories figure-categories-bg">

                                    <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                                </div>
                            </figure>

                            <figcaption>

                                <h3 class="article-title article-title-1">
                                    <a href="https://www.sundayvision.co.ug/28-funny-tweets-about-exercises-that-you-can-read-without-sweat/">
                                        28 funny tweets about exercises that you can read without sweat                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    2 days ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/vihaan/">
                Mia Thompson            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                            </div>

        </div>
    </div>
</div>


                                
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/snowpiercer-is-science-fiction/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.sundayvision.co.ug/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='4934' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0c257f798a" /></p><input type="hidden" id="ak_js" name="ak_js" value="101"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
                            </article>
                        
                    </main><!-- #main -->
                </div><!-- #primary -->
                                
<aside id="secondary" class="widget-area aft-sticky-sidebar">
	<div id="nav_menu-2" class="widget covernews-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span>Navigate</span></h2><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://www.sundayvision.co.ug">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://www.sundayvision.co.ug/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://www.sundayvision.co.ug/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://www.sundayvision.co.ug/economy/">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-534"><a href="https://www.sundayvision.co.ug/science/">Science and Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://www.sundayvision.co.ug/tech/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://www.sundayvision.co.ug/sport/">Sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://www.sundayvision.co.ug/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3528"><a href="https://www.sundayvision.co.ug/contact-form/">Contact Form</a></li>
</ul></div></div><div id="nav_menu-3" class="widget covernews-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span>Pages</span></h2><div class="menu-secondary-menu-container"><ul id="menu-secondary-menu" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2631"><a href="https://www.sundayvision.co.ug/about-us/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2630"><a href="https://www.sundayvision.co.ug/dmca/">DMCA</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2632"><a href="https://www.sundayvision.co.ug/contact-form/">Contact Form</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2673"><a href="https://www.sundayvision.co.ug/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2629"><a href="https://www.sundayvision.co.ug/editorial-policy/">Editorial Policy</a></li>
</ul></div></div>
		<div id="recent-posts-4" class="widget covernews-widget widget_recent_entries">
		<h2 class="widget-title widget-title-1"><span>Recent Posts</span></h2>
		<ul>
											<li>
					<a href="https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/" aria-current="page">&#8220;Snowpiercer&#8221; is science fiction</a>
									</li>
											<li>
					<a href="https://www.sundayvision.co.ug/satellite-images-of-northern-siberia-raise-questions-among-nasa-scientists/">Satellite images of northern Siberia raise questions among NASA scientists</a>
									</li>
											<li>
					<a href="https://www.sundayvision.co.ug/lavrov-reveals-the-details-of-an-american-attack-on-syria/">Lavrov reveals the details of an American attack on Syria</a>
									</li>
											<li>
					<a href="https://www.sundayvision.co.ug/pemex-receives-a-subsidy-of-32000-pesos-from-the-amlo-government-plus-a-tax-credit/">Pemex receives a subsidy of 32,000 pesos from the AMLO government;  Plus a tax credit</a>
									</li>
											<li>
					<a href="https://www.sundayvision.co.ug/ugandan-court-orders-release-of-house-arrest/">Ugandan court orders release of house arrest</a>
									</li>
					</ul>

		</div></aside><!-- #secondary -->
            </div>


</div>


<div class="af-main-banner-latest-posts grid-layout">
    <div class="container">
        <div class="row">

    <div class="widget-title-section">
                    <h4 class="widget-title header-after1">
                        <span class="header-after">

                            You may have missed                            </span>
            </h4>
        
    </div>
    <div class="row">
                <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://www.elcomercio.com/bundles/elcomerciocms/images/icons/social/article-placeholder.jpg">
                                <a href="https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.sundayvision.co.ug/snowpiercer-is-science-fiction/">
                                &#8220;Snowpiercer&#8221; is science fiction                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    16 mins ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/vihaan/">
                Mia Thompson            </a>
        </span>
                    </span>
                                </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://i0.wp.com/sinembargo.mx/wp-content/uploads/2021/02/russia_oli_2016259-2020302-1.jpg">
                                <a href="https://www.sundayvision.co.ug/satellite-images-of-northern-siberia-raise-questions-among-nasa-scientists/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.sundayvision.co.ug/satellite-images-of-northern-siberia-raise-questions-among-nasa-scientists/">
                                Satellite images of northern Siberia raise questions among NASA scientists                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    22 mins ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/frosty-dirac/">
                Leo Adkins            </a>
        </span>
                    </span>
                                </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="http://www.adelante.cu/images/2021/febrero/26/siria/lavrov-580x326.jpg">
                                <a href="https://www.sundayvision.co.ug/lavrov-reveals-the-details-of-an-american-attack-on-syria/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/top-news/" alt="View all posts in Top News"> 
                                 Top News
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.sundayvision.co.ug/lavrov-reveals-the-details-of-an-american-attack-on-syria/">
                                Lavrov reveals the details of an American attack on Syria                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    3 hours ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/aditya/">
                Leland Griffith            </a>
        </span>
                    </span>
                                </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://elfinanciero.com.mx/uploads/2020/03/23/98ed99f6e41584979995_standard_desktop_fullhd.jpeg">
                                <a href="https://www.sundayvision.co.ug/pemex-receives-a-subsidy-of-32000-pesos-from-the-amlo-government-plus-a-tax-credit/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/economy/" alt="View all posts in Economy"> 
                                 Economy
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.sundayvision.co.ug/pemex-receives-a-subsidy-of-32000-pesos-from-the-amlo-government-plus-a-tax-credit/">
                                Pemex receives a subsidy of 32,000 pesos from the AMLO government;  Plus a tax credit                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    4 hours ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/vihaan/">
                Mia Thompson            </a>
        </span>
                    </span>
                                </div>
                    </figcaption>
                </div>
            </div>
                    <div class="col-sm-15 latest-posts-grid" data-mh="latest-posts-grid">
                <div class="spotlight-post">
                    <figure class="categorised-article inside-img">
                        <div class="categorised-article-wrapper">
                            <div class="data-bg data-bg-hover data-bg-categorised"
                                 data-background="https://cdn.cnn.com/cnnnext/dam/assets/210119100930-bobi-wine-house-arrest-twitter-photo-large-169.jpg">
                                <a href="https://www.sundayvision.co.ug/ugandan-court-orders-release-of-house-arrest/"></a>
                            </div>
                        </div>
                                                <div class="figure-categories figure-categories-bg">
                            
                            <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="https://www.sundayvision.co.ug/entertainment/" alt="View all posts in entertainment"> 
                                 entertainment
                             </a>
                        </li></ul>                        </div>
                    </figure>

                    <figcaption>
                        
                        <h3 class="article-title article-title-1">
                            <a href="https://www.sundayvision.co.ug/ugandan-court-orders-release-of-house-arrest/">
                                Ugandan court orders release of house arrest                            </a>
                        </h3>
                        <div class="grid-item-metadata">
                            
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    5 hours ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="https://www.sundayvision.co.ug/author/muhammad/">
                Cynthia Porter            </a>
        </span>
                    </span>
                                </div>
                    </figcaption>
                </div>
            </div>
                </div>
    </div>
    </div>
</div>

<footer class="site-footer">
        
            <div class="secondary-footer">
        <div class="container">
            <div class="row">
                                    <div class="col-sm-12">
                        <div class="footer-nav-wrapper">
                        <div class="footer-navigation"><ul id="footer-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://www.sundayvision.co.ug">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://www.sundayvision.co.ug/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://www.sundayvision.co.ug/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://www.sundayvision.co.ug/economy/">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-534"><a href="https://www.sundayvision.co.ug/science/">Science and Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://www.sundayvision.co.ug/tech/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://www.sundayvision.co.ug/sport/">Sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://www.sundayvision.co.ug/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3528"><a href="https://www.sundayvision.co.ug/contact-form/">Contact Form</a></li>
</ul></div>                        </div>
                    </div>
                                                </div>
        </div>
    </div>
            <div class="site-info">
        <div class="container">
            <div class="row">
                <div class="col-sm-12">
                                                                Copyright &copy; All rights reserved.                                                                            </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>
<style type="text/css">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</style>















<script type='text/javascript' id='fifu-image-js-js-extra'>
/* <![CDATA[ */
var fifuImageVars = {"fifu_lazy":"","fifu_woo_lbox_enabled":"1","fifu_woo_zoom":"inline","fifu_is_product":"","fifu_is_flatsome_active":"","fifu_rest_url":"https:\/\/www.sundayvision.co.ug\/wp-json\/","fifu_nonce":"21f45dbba6"};
/* ]]> */
</script>


<script src='https://stats.wp.com/e-202108.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.3.1',blog:'188553841',post:'4934',tz:'2',srv:'www.sundayvision.co.ug'} ]);
	_stq.push([ 'clickTrackerInit', '188553841', '4934' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.sundayvision.co.ug/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script src="https://www.sundayvision.co.ug/wp-content/cache/min/1/0b5a910d68f89d07df12d54704d119e4.js" data-minify="1" defer></script></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->